Recover a network file, document or folder

Overview

Files and folders stored on network drives (both for individuals and departments) are backed up on a regular basis and can be restored under certain conditions if requested.

Note that backups of network files are done on a nightly basis so it is not possible to recover a file from the same day, though a recovery from the previous day can be done.

  • Full backups of all network files are kept for three months
  • Daily backups are kept for one month

To recover a file, follow the process outlined in the Solution below.

Solution

CAUTION: Students may not request a file restore, the request must come through the student's instructor

 If a file or document on your personal or department network drive has been accidentally deleted, is missing or was accidentally overwritten, the IT Service Desk may be able to recover the file or document.

Before submitting a request to IT, check to see if the file may have been moved to a different folder by doing a search for the file.

If you are still unable to recover the file, submit a request for file recovery to the IT Service Desk using the Ask IT form. Please include the following information:

  • The name of the file or files. If you do not know the exact name include as much information on the name as possible.
  • The name of the folder the file should be in, including the full network drive path. For example: J:\ICs\Example folder\example.docx
  • The time/date of the last known working version of the file. If the exact time is not known, offer the best guess.

Symptoms

A network file, folder or document is missing, damaged or its content is incorrect.

Cause

Cause can vary but may include:

  • accidentally overwriting the file with incorrect or unwanted changes
  • accidental deletion of file
  • software corruption damaging the file
  • other user moving the file or folder to a new location (not actually missing)

Details

Article ID: 1770
Created
Fri 8/20/21 8:33 AM
Modified
Sat 2/19/22 2:21 PM
Environment
Enter the environment(s) in which this article is relevant. Eg. software name and specific version, OS(s), model of hardware, location, etc.
Network drives
Windows 7
Windows 8.1
Windows 10
macOS