My Media page not loading in Brightspace in Safari

Summary

Allow third party cookies in Safari or switch to another browser such as Google Chrome or Firefox

Body

Overview

If you are using the MacOS Safari browser and My Media is not loading in Brightspace third party cookies may be blocked. This will prevent the My Media page from displaying contents correctly.

Solution 

To allow third party cookies, follow these steps in Safari:

  1. Go to the Safari menu and select Preferences
  2. Click the Privacy tab
  3. The next step will vary based on the version of Safari installed. Follow the appropriate step below:
    • Under Cookies and website data select Always Allow or Allow from current website only
    • Under Cookies and website data uncheck Block all cookies

Symptoms

The following message may appear on the My Media page:

It seems your browser is blocking third party session cookies which are required for the Kaltura application. To resolve this issue, please update your settings to allow third party cookies.

Work-Around

Other browsers such as Google Chrome or Firefox can be used as they do not block third party cookies.

Cause 

Third party cookies are blocked.

Details

Details

Article ID: 3174
Created
Fri 3/4/22 2:57 PM
Modified
Sat 3/12/22 2:21 PM
Environment
Enter the environment(s) in which this article is relevant. Eg. software name and specific version, OS(s), model of hardware, location, etc.
Brightspace by D2L
Safari web browser
MacOS